[Цитировать]

    agrei678
  • 2874
  • Стаж: 2 года 9 месяцев
  • Сообщений: 23
  • Репутация:0

    [+] [-]
  • Откуда: Россия.,Екатеринбург.
подскажите пожалуйста, а у 10-и какие строки править нужно ? aa

[Цитировать]

    vovan1982
  • 214
  • Стаж: 3 года 10 месяцев
  • Сообщений: 699
  • Репутация:52

    [+] [-]
  • Откуда: Ростов-на-Дону
agrei678, вам интересно упражняться с Hex редактором? Воспользуйтесь http://usbtor.ru/viewtopic.php?t=143

[Цитировать]

    KottoSOFT
  • 206
  • Стаж: 3 года 10 месяцев
  • Сообщений: 648
  • Репутация:44

    [+] [-]
Привет, всем снова в очередной раз залез в эту тему, появилась идея (вернее даже сборка) Windows 7 13 in 1 с 11тью языками интегрированными мною, все редакции в одном файле с языками и обновлениями даже пережатая в ESD получается 4,35 ГБ (4 675 447 830 байт) многовато, решил не объединять разрядности там вполне Божеский размер, хочу их закинуть на флешку со структурой папок:KSFT\BOOT\W7X86\W7X64 два boot wim в папку BOOT со всеми сопровождающими файлами в папки по разрядностям ESD шки.
В файле BCD прописать запуск 2х BOOT.WIM особой трудности не вижу, взял для начала обученный сегодня читать ESD 32x битный 7чный boot.wim закинул в папку MU всё, как в шапке темы, прописал в скрипте путь к папке с 32Х битным ESD нажал Энтер голяк ничего не выполнено. Вот пока пишу думаю может из за того, что boot.wim модифицирован?
А если чистый файл обработать, а после модифицировать, не потеряет ли он прописанный путь.?

[Цитировать]

    sergeysvirid
  • 104
  • Стаж: 4 года
  • Сообщений: 1408
  • Репутация:81

    [+] [-]
  • Откуда: 65 регион (GMT+11)
KottoSOFT,
Привет! aa
Скинь на Я.Д. свою сборку (именно в том виде, в каком она есть на флешке) только без файлов инсталляций install.esd
Явно где-то, что-то упустил или в boot.wim'ах в скрипте поиска install.esd неверно указан путь.

[Цитировать]

    KottoSOFT
  • 206
  • Стаж: 3 года 10 месяцев
  • Сообщений: 648
  • Репутация:44

    [+] [-]
sergeysvirid,
Привет, хорошо чуть позже. Скинул архив в личку.

[Цитировать]

    KottoSOFT
  • 206
  • Стаж: 3 года 10 месяцев
  • Сообщений: 648
  • Репутация:44

    [+] [-]
Загрузка Windows 7 из одной папки.
Приветствую, друзья и снова возвращаюсь к этой теме.
Не то, чтобы не было адекватных загрузчиков.
Благодаря нашим друзьям товарищам Xemom1, Conty9 puhpol и многим другим этого добра хватает.
Но тем не менее поиск новых решений тоже остаётся, актуальным.
В данном эксперименте интегрировал языки в два boot.wimx86\x64 соответственно.
Интегрировал, а вернее добавил в ручную скрипт подсказанный sergeysvirid ом
Напрямую в папку Windows\System32

Содержание скрипта

@echo off
setlocal enabledelayedexpansion
SET DD=KSFT
SET MM=Win
SET IN=NI
for %%I in (C D E F G H I J K L M N O P Q R S T U V W X Y Z) do (
set IP=%%I:\!DD!\!MM!
dir /d !IP!\install.wim&&set IN=!IP!\install.wim
dir /d !IP!\install.esd&&set IN=!IP!\install.esd
dir /d !IP!\install.swm&&set IN=!IP!\install.swm
dir /d !IP!\install.rg&&set IN=!IP!\install.rg
IF !IN! NEQ NI goto :INST
)
IF %IN% EQU NI (
echo ERROR - COULD NOT FIND INSTALL.WIM(ESD,SWM) in %DD%\%MM% folder!
pause
pause
goto:RBT
)
:INST
echo %IP%
if exist %IP%\autounattend.xml SET UN=/unattend:%IP%\autounattend.xml
if exist %IP%\unattend.xml SET UN=/unattend:%IP%\unattend.xml
if exist %IP%\_unattend.xml SET UN=/unattend:%IP%\_unattend.xml
if exist %IP%\OEM\nul SET OEM=/m:%IP%\OEM
if exist %IP%\$OEM$\nul SET OEM=/m:%IP%\$OEM$
set ST=X:\Setup.exe
if exist %IP%\Setup.exe set ST=%IP%\Setup.exe
if not exist %ST% goto :BAD
cd /d %IP%
%ST% /installfrom:%IN% %OEM% %UN%
goto :RBT
:BAD
dir X:\ /b
echo Cannot find %ST% !
echo.
:RBT
exit
@echo Press a key to reboot now...
pause
wpeutil reboot
pause
:QUIT
exit
Туда же добавил файлик winpeshl

winpeshl

[LaunchApps]
startnet.cmd
winsetup.cmd
Хотя в оригинале он должен был быть таким

Оригинал winpeshl

[LaunchApps]
startnet.cmd
mysetup.cmd
Разница обусловлена тем, что скрипт был переименован из mysetup.cmd в winsetup.cmd что в конечном итоге не должно влиять на запуск и не влияет.
Вто только выглядит всё немного не так, первым появляется окно командной строки с запуском wpe.init чуть погодя мелькает скрипт и начинается стандартная установка.
Всё отрабатывает хорошо система ставится, но диалоговые окна несколько нетрадиционно выглядят. Вот смотрите

Скриншоты

Кто подскажет, что у меня не так????????????????

[Цитировать]

    sergeysvirid
  • 104
  • Стаж: 4 года
  • Сообщений: 1408
  • Репутация:81

    [+] [-]
  • Откуда: 65 регион (GMT+11)
54346Кто подскажет, что у меня не так????????????????
Привет! aa
Нужно подправить в boot.wim\sources\ru-ru\spwizres.dll.mui
Заменить в spwizres.dll.mui=>Диалог ресурсы 104, 2018, 3000 на эти spwizres.dll.mui-Диалог.7z


Последний раз редактировалось: sergeysvirid (2018-06-03 14:38), всего редактировалось 1 раз

[Цитировать]

    KottoSOFT
  • 206
  • Стаж: 3 года 10 месяцев
  • Сообщений: 648
  • Репутация:44

    [+] [-]
sergeysvirid,
Спасибо, дружище!!!!!!!!!!!!

Страница 18 из 18


Показать сообщения:    

Текущее время: 15-Дек 17:15

Часовой пояс: UTC + 3


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете голосовать в опросах
Вы не можете прикреплять файлы к сообщениям
Вы можете скачивать файлы