[Quote]

    h0rse
  • 26352
  • Longevity: 4 months 4 days
  • Posts: 9
  • REPUTATION:-1

    [+] [-]
Никак не хочет загружаться с флешки в режиме UEFI без secureboot
синий экран и ошибка:
файл: \windows\system32\boot\winload.efi
Код ошибки: 0xc0000359
хотя этот же wim файл в legacy режиме грузится нормально.
Подозреваю что в режиме UEFI проверяется CRC wim образа к примеру boot.wim из состава образа установочной винды грузится нормально.

[Quote]

    dimo70
  • 17296
  • Longevity: 3 years 4 months
  • Posts: 2111
  • REPUTATION:29

    [+] [-]
  • Location: BG
h0rse, вы сделали то, что я вам рекомандовал?
Другой вариант через Rufus.

[Quote]

    Gemostarter
  • 15956
  • Longevity: 4 years
  • Posts: 250
  • REPUTATION:35

    [+] [-]
82030Подозреваю что в режиме UEFI проверяется CRC wim образа
Нет. Только цифровые подписи efi-файлов, ядра и драйверов, и только с включённым SecureBoot.
82030
файл: \windows\system32\boot\winload.efi
Код ошибки: 0xc0000359
Эта ошибка означает "файл отсутствует или повреждён". Значит, внутри wim нет файла "\windows\system32\boot\winload.efi". Скорее всего, он есть по пути "\windows\system32\winload.efi", правим пункт в меню BCD на флэшке (программой bootice, например).
Заглянуть внутрь wim можно архиватором 7-zip, например. Или смонтировать в каталог с помощью dism.

[Quote]

    h0rse
  • 26352
  • Longevity: 4 months 4 days
  • Posts: 9
  • REPUTATION:-1

    [+] [-]
Эта ошибка означает "файл отсутствует или повреждён". Значит, внутри wim нет файла "\windows\system32
файл есть как в \Windows\System32\boot\winload.efi так же я его скопировал в \Windows\System32\ мало ли он там ищется. в BCD прописан путь \windows\system32\boot\winload.efi
82034h0rse, вы сделали то, что я вам рекомандовал?
Другой вариант через Rufus.
чем мне может помочь Rufus у меня не ISO образ (про WinPE 10-8 Sergei Strelec и так все понятно, на торрентах все пишут что не работает UEFI) да кстати такая же беда с ним как у меня на моей сборке.
тут 2 варианта как мне кажется.
1 - загрузчик не ищет файл на виртуальном диске (в случае с winpe это X:\), а на физическом.
2 - при распаковке в память неверная контрольная сумма исходного boot.wim из которого делался winpe.
--
у меня флешка сделана так:
в legacy режиме через bootmgr в настройках BCD грузится grub4dos где моя winpe грузится через iso
в uefi режиме уже идет загрузка через bootmgr.efi и также через EFI\Microsoft\Boot\bcd где прописан boot.wim по пути \boot\boot.wim
интересно что в QemuBootTester ошибки нет, она есть только на живых системах

[Quote]

    dimo70
  • 17296
  • Longevity: 3 years 4 months
  • Posts: 2111
  • REPUTATION:29

    [+] [-]
  • Location: BG
С MLF и нового загрузчика GRUB2 от Canonical в UEFI вообще проблем нет. Если wim не сломанный загрузиться без проблем.

[Quote]

    h0rse
  • 26352
  • Longevity: 4 months 4 days
  • Posts: 9
  • REPUTATION:-1

    [+] [-]
82039С MLF и нового загрузчика GRUB2 от Canonical в UEFI вообще проблем нет. Если wim не сломанный загрузиться без проблем.
grub2 не умеет грузить wim образы. провозился дня 2 так и не смог заставить.
так же iso не смог загрузить. grub2 вобще похоже only linux. он умеет только подхватывать загрузку с bootmgr.efi толку от него? у меня и так подхватывается bootmgr.efi без всякого груба и ошибка далее.

[Quote]

    волчара
  • 253
  • Longevity: 6 years 2 months
  • Posts: 511
  • REPUTATION:15

    [+] [-]
  • Location: Омск
82037про WinPE 10-8 Sergei Strelec и так все понятно, на торрентах все пишут что не работает UEFI
Это кто пишет то и на каких торрентах? fp , все прекрасно загружается в efi x64bit(на с чет x86 не скажу, у мну нет такого железа), даже на такой проблемной мамке как GIGABYTE B460M AORUS PRO и то загружается хоть с включенным SecureBoot, хоть с отключенным. ae
Теперь по поводу ошибки в efi: Однозначно причину указать нельзя, но часто появляется из-за того что файл bootmgr.efi как и сам boot.wim повреждены, а происходит это когда не коректно скачен образ винды, т.е. нужно проверить хеш суммы самого образа из которого вы взяли bootmgr.efi и boot.wim, если все в порядке тогда нужно смотреть сам bcd файл. Попробуйте добавить это значение DisableIntegrityChecks | True
82037загрузчик не ищет файл на виртуальном диске (в случае с winpe это X:\), а на физическом.
Загрузчик ищет там откуда он запущен, если конечно он не модифицированный, попробуйте запустить россыпью, т.е. из папки SSTR.
82037интересно что в QemuBootTester ошибки нет, она есть только на живых системах
Бывает и так, что на виртуалке не работает, а на реальном железе все прекрасно загружается.

[Quote]

    h0rse
  • 26352
  • Longevity: 4 months 4 days
  • Posts: 9
  • REPUTATION:-1

    [+] [-]
Теперь по поводу ошибки в efi: Однозначно причину указать нельзя, но часто появляется из-за того что файл bootmgr.efi как и сам boot.wim повреждены, а происходит это когда не коректно скачен образ винды, т.е. нужно проверить хеш суммы самого образа из которого вы взяли bootmgr.efi и boot.wim
bootmgr.efi собсно все загрузочные файлы взятиз образа винды 8.1
boot.wim как может быть контрольная сумма другая? это winpe эта сумма постоянно меняется так как сборка постоянно обновляется и пересобирается
если все в порядке тогда нужно смотреть сам bcd файл. Попробуйте добавить это значение DisableIntegrityChecks | True
DisableIntegrityChecks включено

Картинка

[Quote]

    волчара
  • 253
  • Longevity: 6 years 2 months
  • Posts: 511
  • REPUTATION:15

    [+] [-]
  • Location: Омск
h0rse,
Вы меня не поняли, проверить не вим файлы, а сам образ из которого вы вытащили файлы, повторюсь возможно не коректно с качался сам образ, особенно это бывает когда скачиваешь с торрентах, так же пару раз не совпадали суммы когда скачивал с яндекса. Так же у меня было что не коректно скопировался сам бутвим, из-за кратковременного зависания флешки, тоже надо бы проверять, что бы исключить варианты из-за чего ошибка, и еще хотел сказать,я в своих сборках не пользуюсь bootmgr.efi, ибо он мне без надобности, т.к. есть \efi\boot\bootx64.efi и этого в полне достаточно(пока)
Добавлено через 5 минут 19 секунд:
h0rse, А еще такой вопрос, вы случаем Winpex86 не на 64 битной машине загружаете?

[Quote]

    h0rse
  • 26352
  • Longevity: 4 months 4 days
  • Posts: 9
  • REPUTATION:-1

    [+] [-]
Что значит не на х64 машине? В установочном образе винды в пути \efi\boot\ х86 лежит только bootia32.efi в х64 лежит только bootx64.efi когда сборщики объединяют редакции то там лежат 2 файла сразу и BIOS грузит автоматически х64 если доступно, а если нет то х86
UEFIx86 работает в виртуалке но не работает на железе (проверено на 20+ ноутбуках и 2 десктопах)
UEFIx64 не работает не там не там.
тоже самое с wim от WinPE 10-8 Sergei Strelec я скачал сборку ради интереса проверить тут же пишут что 146% все работает.
bootmgr.efi я просто не убирал с флешки, я не знаю как bios грузит может можно и без него.

[Quote]

    SergeyZV
  • 528
  • Longevity: 6 years
  • Posts: 749
  • REPUTATION:10

    [+] [-]
82044UEFI грузится как х86 так и x64 если доступно.
UEFI x86 может грузиться на планшетах и некоторых нетбуках. X64 на ПК и ноутбуках. WinPE 10-8 Sergei Strelec россыпью в UEFI грузится без проблем.

[Quote]

    AZJIO
  • 17953
  • Longevity: 3 years 1 month
  • Posts: 623
  • REPUTATION:75

    [+] [-]
Проверить chkdsk`ом
Ощущение, что проблема в \EFI\BOOT\bootia32.efi или bootmgr.efi
В Grub2 может поменяться цепочка на \EFI\BOOT\grubia32.efi
Если на qemu работает в режиме EFI, то образ целый. Только qemu использует свой биос. Может проблема как раз в связке биоса + bootia32.efi. Биос на 20 ноутбуках вряд ли поломан, остаётся bootia32.efi.
bootmgr.efi выполняет параметры BCD, поэтому если он поломан, тоже будет проблема.

[Quote]

    волчара
  • 253
  • Longevity: 6 years 2 months
  • Posts: 511
  • REPUTATION:15

    [+] [-]
  • Location: Омск
82044UEFI грузится как х86 так и x64 если доступно.
Вы уверенны в этом?
82044UEFIx86 работает в виртуалке но не работает на железе (проверено на 20+ ноутбуках и 2 десктопах)
Еще раз говорю, не будет работать
82044
UEFIx64 не работает не там не там.
тоже самое с wim от WinPE 10-8 Sergei Strelec
А я говорю что все работает и что бы не быть голословным по всем этим вопросам вот вам видео, специально счас добавил пункт WinPEx86 в загрузку х64bit
КИНО
Добавлено через 4 минуты 42 секунды:
AZJIO, aa
дело в том что файл \EFI\BOOT\grubia32.efi не запустится на 64 разрядной машине проверенно не однократно, ибо надо 86 разрядную машину(мамку), а если данный пункт WinPEx86 добавить в bcd для загрузки х64 то выскакивает данная ошибка, вот как то так ab
Добавлено через 6 минут 27 секунд:
SergeyZV, aa
Это раньше было в старых сборках сергея стрельца, счас увы, на видео что я счас дал все прекрасно видно.
Добавлено через 18 минут 13 секунд:
То что на видео, там мамка 2015 года выпуска(на сколько я помню), с час проверил на ноуте асус 2019 и стационаре мамка 2020 года выпуска и результат один с WinPEx86 ошибка, что с включенным или отключенным SecureBoot

[Quote]

    AZJIO
  • 17953
  • Longevity: 3 years 1 month
  • Posts: 623
  • REPUTATION:75

    [+] [-]
волчара, я лишь привёл как цепочку, никто не мешает положить в папку grubx64.efi

[Quote]

    волчара
  • 253
  • Longevity: 6 years 2 months
  • Posts: 511
  • REPUTATION:15

    [+] [-]
  • Location: Омск
82044лежат 2 файла сразу и BIOS грузит автоматически х64 если доступно, а если нет то х86
Да лежат, Но один файл предназначен для загрузки чисто 64 битной архитектурной системе, а другой 86 и не как иначе, 64 битная система ни загрузит 86 и на оборот.
Добавлено через 3 минуты 48 секунд:
82048никто не мешает положить в папку grubx64.efi
так он ему не нужен, ибо он загружается не из grub2, а bootx64.efi>bcd

Page 1 of 2


Display posts:    

Current time is: 13-Apr 00:46

All times are UTC + 3


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum